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The sending of newsletters is the basis of an efficient email marketing communication for small 
to large companies. All eMill editions include the necessary tools to automate the management 
of a subscribers list: creation of a subscription form, processing of subscriptions and 
unsubscriptions, live list update… 

This eMill tutorial aims at guiding you to set up the management of your subscribers list. Note 
that the tutorial first part is based on the fact that you do not have started to build a list. If 
you already have a subscription form on your website and if you wish to use eMill to update 
automatically your list, you must read the second part of this tutorial. 

 

1. Starting the management of a subscribers list with eMill 

 

By using the Opt-In management module, eMill provides you with all the tools to create a 
personalized subscription form and to deal automatically with subscription and unsubscription 
requests. 

 

1.1 E-mail as the communication medium between eMill and your subscribers 

During this tutorial, you will see that the e-mail is used to carry the information about a 
subscription or an unsubscription.  

Therefore, to start, you must select one of your email addresses which will be used for this 
communication. Then, configure an incoming queue corresponding to this email address from 
the Tools > Options, Incoming queues tab (POP3 account or file). For more details on how 
you can configure an incoming queue, please refer to the appropriate help section. 

Note that this email address does not have to be reserved for eMill and that this step is 
independent and can be done at the end of the tutorial. 

 

1.2 Create a new mailing project 

From the File > New menu, select ‘Empty mailing project’ and click on OK. 
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Enter a name and a description for the new project and click on ‘Finish’. 

 

 

 

1.3 Create a new list 

This list will be used to store the contact details you collect when someone subscribes to your 
newsletter. Therefore, each question of your subscription form must correspond to a column in 
the list. 

For instance, if I ask for the e-mail address, the name, the first name and the company name 
in my subscription form, I must have a name, a first name, a company name and an email 
address column in my list. 
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To add a new list to your project, go to the Project > Add a receivers list menu. Enter a list 
name and click on ‘Next’. 

 

 

Select the data source type ‘I don’t have a database, create one for me’ and click on 
‘Next’ and ‘Finish’. 
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The list is displayed in the project tree under ‘Receivers lists’. When you select it, its content is 
displayed in the right window. You can see that the list already contains default columns. If 
you want to add or remove columns so that they match your subscription form questions, go 
to the Project > List > Add new column / Delete column. 

 

 

 

1.4 Configure the automatic list update 

 

Select the list you have just created in the project tree and click on the ‘Tools > Opt-In 
Management’ menu. 

Click on ‘Next’ to run the wizard. 
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Creation of the subscription form 

The first step is to create a subscription form that will be inserted on your website in order to 
let your visitors subscribe to your newsletter. 

To create it you must: 

-  Define the questions that will be displayed in the subscription form. The table 
lists all your list columns. For each of these, you must decide if a new subscriber must 
compulsorily answer the question (check the ‘mandatory’ box) or if it is optional (check 
the ‘optional’ box). If none boxes are checked, the question will not be added to the 
form. In the example below, I’m going to create a form where the new subscriber will 
have to give his e-mail (mandatory), his first name (optional) and his last name 
(mandatory). 

 

 

 

- The redirection URL. You must provide an address of a web page that will be 
displayed to the new subscriber once he submits the form. This address can be your 
website homepage or a page where you thank the visitor for subscribing. 

- Email Address. Enter the email address defined in 1.1. When a visitor of your website 
submits the subscription form, all the data he provides are sent by email to this 
address. 
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The confirmation message 

Click on ‘Next’ 

 

 

 

The confirmation message is automatically sent to a new subscriber when submitting the 
subscription form. It is part of the double opt-in process allowing a subscriber to confirm his 
subscription. Indeed, a lot of dishonorable consumers subscribe people to hundreds of list 
without their permission. Thereby bombarding these people with hundreds of unsolicited email 
messages. The double opt-in process provides you the added protection of a confirmation link 
that must be clicked by the new subscriber. 

 

eMill lets you edit the confirmation message (message subject and body) in HTML like any 
other message. You can edit it by inserting your own text between the <body> and </body> 
tags. If you want to insert rich text, images or tables you can either write directly the 
appropriate HTML code or use the eMill HTML Editor and copy/paste the HTML code here. 

 

You also have the possiblity to personalize the confirmation message using the information the 
new subscriber has provided when submitting the subscription form. Use the following syntax: 
%NameOfTheField%. For instance, if you ask for the First Name in the opt-in form, you can 
start your confirmation message by "Hi %FirstName%,". 

 

Note that the confirmation message contains a link that should not be deleted: "<a 
href="%SubscribeLink%">here</a>". Indeed, it contains the information for your system to 
identify the subscriber and confirm its subscription. 
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Insert the subscription form in your website 

Click on ‘Next’ 

 

 

Now, you just need to insert the subscription form you have just created in your website. Start 
by selecting the whole HTML code included in the window. 

Then, open one of your website page within an HTML editor. If you use a WYSIWIG HTML 
editor, switch to the ‘Code’ view. Finally, paste the form code where you want it to be 
displayed. 

 

The message rules 

Click on ‘Finish’ 

The message rules are created in order to automate the processing of subscription and 
unsubscription requests. When a window asks you if you want to publish your project, answer 
‘Yes’ in order to validate the creation of the rules.  

 

 

 

When the publish dialog box is displayed, uncheck all the boxes under ‘Once the project is 
published’, and, under ‘Subscribed incoming queues’, check the box corresponding to the 
incoming queue you created in 1.1.  
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To give you more details, here is an explanation of what the rules are doing: 

- Subscription: As we explained above, when a visitor of you website submits the 
subscription form, an email including all his contact details is sent to the email address 
defined in 1.1. The ‘Subscription’ rule tells eMill to download this email and to update 
your list using the information provided by the new subscriber. 

- Unsubscription: The management of a subscribers list implies that you process 
rigorously unsubscription requests. In each newsletter you send, you must insert a link 
allowing the receiver to unsubscribe from your list. To insert this link when creating a 
message with eMill, go to the ‘Insert > Unsubscribe link’ menu. 

When a subscriber clicks on the unsubscribe link, an email including his contact details 
is sent to the email address defined in 1.1. The ‘Unsubscription’ rule tells eMill to 
download this email and to delete the subscriber from your list. 

 

The configuration of eMill is over. All the maintenance of your list is now automated. You just 
have to concentrate on creating and broadcasting your newsletter. 
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2. How to create the message rules 

 

If you already have a subscription form or if you want to create it using another tool than the 
eMill Opt-In Management module, you can automate the maintenance of your subscribers list 
with eMill. Note that this system can only be used if you receive the subscription or 
unsubscription requests by e-mail on one of your email addresses. 

The second part of the tutorial details how you can configure the message rules to process 
these requests. They will allow eMill to automatically download the subscription or 
unsubscription emails and to update your list with the information included in these emails. 

First, follow the steps described in 1.1 (incoming queues), 1.2 (create a new project) and 1.3 
(create a new list). Then, to start configuring the message rules, go to the Project > 
Message rule menu. 

 

2.1 Specify the download conditions 

 

If the email address used to receive the information on a new subscriber is not reserved for 
this particular use, you must define download conditions to avoid all the received emails being 
downloaded by eMill. 

Click on the ‘Download’ tab, check the ‘Test the following conditions’ option and click on 
‘Add’. 
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Speaking generally, in order to detect a subscription or an unsubscription request, we use 
keywords included in the email subject. For instance, an email including information on a new 
subscriber will have as a subject ‘Subscribe form’ and an unsubscription request will have as a 
subject ‘Unsubscribe’.  

In the first window, select the ‘Find values in the subject’ option. 

 

In the ‘Criteria’ field, select ‘contains any’ and enter under ‘Value(s)’ the text: Subscribe, 
Unsubscribe. An email will be downloaded within your eMill inbox only if its subject line 
contains ‘Subscribe’ or ‘Unsuscbribe’. 
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Click on ‘Finish’ 

 

2.2 Processing subscription requests 

 

This step lets you configure eMill to retrieve the information provided by a new subscriber in 
order to update your list. Before configuring the rule, it is important to note that: 

- Your subscribers list must contain a column corresponding to each question of the 
subscription form.  

- The content of the received email must be structured as follow: 

Form question: Subscriber’s answer 

(i.e., Name: Jones) 

Note that the character ‘:’ can be replaced by ‘=’. If the answer is written on multiple 
lines, it must be between ‘«’ and ‘»’. 

Click on the ‘General’ tab, check the ‘Apply the following rule(s)’ option and click on ‘Add’.  

 

Conditions to execute a message rule 

The first step to create a message rule is to define when it has to be executed. As we did 
above (2.1), we are going to use the text of the subject line to detect an email for a 
subscription request.  

Click on the first ‘Add’ button 

Select the ‘Find values in the subject’ option and click on ‘Next’. 

 

 

 



Tutoriel eMill – La gestion d’une liste d’abonnés avec eMill 

©2001-2007 eMill Tutorial – Managing a subscribers list with eMill   13 / 21 
 
 
 

In the ‘Criteria’ field, select ‘contains any’ and enter under ‘Value(s)’ the following text: 
Subscribe.  

 

 

 

Click on ‘Finish’ 
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The message rule 

The second step is to define the action that will be executed when a subscription request is 
detected. In this tutorial, the action is to use the information on the new subscriber included in 
the email to update the list. 

Click on the second ‘Add’ button. 

Select the ‘Add a record to a data source’ option and click on ‘Next’. 
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Select the ‘A project receivers list’ option and the subscribers list you have created at the 
beginning of the tutorial.  

 

The following window is displayed: 

 

 

On the left, the subscribers’ list columns are listed; on the right, you have to indicate which 
value included in the email corresponds to the column.  

For instance, select the ‘E-mail’ column and click on ‘Edit’.  
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We have seen previously that in the body of the received email, the information is presented 
as follow: E-mail address: Subscriber’s email address. 

Therefore, the ‘E-mail’ column has to be updated with the information of the ‘E-mail address’ 
field included in the message body.  

Select in the list the ‘Field from the message body’ option and write on the right: E-mail 
address. 

 

 

Click on ‘OK’ and repeat the operation for each information you want to retrieve from the 
received email.  

 

Click on ‘Finish’ and ‘OK’. 

 

2.3 Processing unsubscription requests 

 

This section lets you configure eMill to detect unsubscription requests, retrieve the information 
on the subscriber and remove him from the list. In this example, we assume that the 
unsubscription request has in its subject line « Unsubscribe SubscriberEmailAddress ». This is 
the format of the email you receive if you insert the eMill unsubscribe link in your newsletter. 
 
Click on the ‘Add’ button. 
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Conditions to execute a message rule 

The first step to create a message rule is to define when it has to be executed. As we did 
above (2.2), we are going to use the text of the subject line to detect an email for an 
unsubscription request.  

Click on the first ‘Add’ button 

Select the ‘Find values in the subject’ option and click on ‘Next’. 

 



Tutoriel eMill – La gestion d’une liste d’abonnés avec eMill 

©2001-2007 eMill Tutorial – Managing a subscribers list with eMill   18 / 21 
 
 
 

In the ‘Criteria’ field, select ‘contains any’ and enter under ‘Value(s)’ the following text: 
Unsubscribe.  

 

 

Click on ‘Finish’ 

 



Tutoriel eMill – La gestion d’une liste d’abonnés avec eMill 

©2001-2007 eMill Tutorial – Managing a subscribers list with eMill   19 / 21 
 
 
 

The message rule 

The second step is to define the action that will be executed when an unsubscription request is 
detected. In this tutorial, the action is to delete the subscriber profile from the list. 

Click on the second ‘Add’ button. 

Select the ‘Delete a record from a data source’ and click on ‘Next’. 
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Select the ‘A project receivers list’ option and the subscribers list you have created at the 
beginning of the tutorial.  

 

 

The following window is displayed: 

 

This step allows you to specify which subscriber profile will be deleted. We are going to define 
the fact that the subscriber to remove from the list is the one whose email address matches 
the address in the unsubscription request subject line. 
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Select the list column containing your subscribers email addresses (here, it is ‘Email’) and click 
on ‘Edit’.  

In the last list, select the ‘Email address extracted from the subject’ option. 

 

Click on ‘OK’, ‘Finish’ and ‘OK’ 

 

Subscription and unsubscription requests will now be processed automatically.  

However, be sure to always subscribe your eMill project to the incoming queue created at the 
beginning of the tutorial by checking the appropriate box when publishing the project. 

 

 

 

 

 


